ERROR: Unsatisfiable requirements detected for package CUDNN [161a31e8]


#1

我需要运行一个工程,需要加载CUDNN和CUDArt,但是安装CUDNN是出现了上述问题,相似的CUDArt也是。这这意味着什么,google上也没有相应的主题。

安装CUDNN
(v1.0) pkg> add CUDNN
Updating registry at ~/.julia/registries/General
Updating git-repo https://github.com/JuliaRegistries/General.git
Resolving package versions…
ERROR: Unsatisfiable requirements detected for package CUDNN [161a31e8]:
CUDNN [161a31e8] log:
├─possible versions are: [0.0.1, 0.1.0-0.1.1, 0.2.0-0.2.1, 0.3.0, 0.4.0] or uninstalled
├─restricted to versions * by an explicit requirement, leaving only versions [0.0.1, 0.1.0-0.1.1, 0.2.0-0.2.1, 0.3.0, 0.4.0]
└─restricted by julia compatibility requirements to versions: uninstalled — no versions left
安装CUDArt
(v1.0) pkg> add CUDArt
Updating registry at ~/.julia/registries/General
Updating git-repo https://github.com/JuliaRegistries/General.git
Resolving package versions…
ERROR: Unsatisfiable requirements detected for package CUDArt [58537def]:
CUDArt [58537def] log:
├─possible versions are: [0.0.1, 0.1.0-0.1.3, 0.2.0-0.2.3, 0.3.0-0.3.2, 0.4.0-0.4.1] or uninstalled
├─restricted to versions * by an explicit requirement, leaving only versions [0.0.1, 0.1.0-0.1.3, 0.2.0-0.2.3, 0.3.0-0.3.2, 0.4.0-0.4.1]
└─restricted by julia compatibility requirements to versions: uninstalled — no versions left


#2

不支持当前版本吧,看上去这两个包都只支持到 0.4.0。一定要用可能就得用老版的 julia,或者去 github 上看看他们的源码,反正都是个 wrapper 可以 fork 一个出来改一改,让它支持 1.0


#3

请问修改有没有教程,刚入手,但是这边实验催的紧。或者修改有没有什么要求,谢谢


#4

直接用0.5,0.4版本看看


#5

额,我在Ubuntu 18.04上可以正常使用,Julia 版本 1.0.1,CUDNN 已经deprecated了,相关功能都在 CuArrays 里面。