JuliaFEM安装问题


#1

麻烦大家我想问一个问题 :grinning:
更新到JuliaPro 1.0.1.1(Julia 1.0.1)之后,安装一个JuliaFEM的包时,发生了如下问题:

julia> using Pkg

julia> Pkg.add("JuliaFEM")
  Updating registry at `D:\JuliaPro-1.0.1.1\pkgs-1.0.1.1\registries\JuliaPro`
  Updating git-repo `https://pkg.juliacomputing.com/registry/JuliaPro`
ERROR: The following package names could not be resolved:
 * JuliaFEM (not found in project, manifest or registry)
Please specify by known `name=uuid`.
Stacktrace:
 [1] pkgerror(::String) at C:\Users\julia\AppData\Local\Julia-1.0.1\share\julia\stdlib\v1.0\Pkg\src\
Types.jl:121
 [2] #ensure_resolved#43(::Bool, ::Function, ::Pkg.Types.EnvCache, ::Array{Pkg.Types.PackageSpec,1})
 at C:\Users\julia\AppData\Local\Julia-1.0.1\share\julia\stdlib\v1.0\Pkg\src\Types.jl:897
 [3] #ensure_resolved at .\none:0 [inlined]
 [4] #add_or_develop#13(::Symbol, ::Bool, ::Base.Iterators.Pairs{Union{},Union{},Tuple{},NamedTuple{
(),Tuple{}}}, ::Function, ::Pkg.Types.Context, ::Array{Pkg.Types.PackageSpec,1}) at C:\Users\julia\A
ppData\Local\Julia-1.0.1\share\julia\stdlib\v1.0\Pkg\src\API.jl:59
 [5] #add_or_develop at .\none:0 [inlined]
 [6] #add_or_develop#12 at C:\Users\julia\AppData\Local\Julia-1.0.1\share\julia\stdlib\v1.0\Pkg\src\
API.jl:29 [inlined]
 [7] #add_or_develop at .\none:0 [inlined]
 [8] #add_or_develop#11 at C:\Users\julia\AppData\Local\Julia-1.0.1\share\julia\stdlib\v1.0\Pkg\src\
API.jl:28 [inlined]
 [9] #add_or_develop at .\none:0 [inlined]
 [10] #add_or_develop#10 at C:\Users\julia\AppData\Local\Julia-1.0.1\share\julia\stdlib\v1.0\Pkg\src
\API.jl:27 [inlined]
 [11] #add_or_develop at .\none:0 [inlined]
 [12] #add#18 at C:\Users\julia\AppData\Local\Julia-1.0.1\share\julia\stdlib\v1.0\Pkg\src\API.jl:69
[inlined]
 [13] add(::String) at C:\Users\julia\AppData\Local\Julia-1.0.1\share\julia\stdlib\v1.0\Pkg\src\API.
jl:69
 [14] top-level scope at none:0

julia> Pkg.status()
    Status `D:\JuliaPro-1.0.1.1\pkgs-1.0.1.1\environments\JuliaPro_v1.0.1.1\Project.toml`
  [c52e3926] Atom v0.7.6
  [a93c6f00] DataFrames v0.14.1
  [7073ff75] IJulia v1.12.0
  [682c06a0] JSON v0.19.0
  [e5e0dc1b] Juno v0.5.3
  [438e738f] PyCall v1.18.4
  [d330b81b] PyPlot v2.6.3

有的库可以安装成功,有的就不行,请问一下这是为什么啊 :sweat_smile:


#2

] 进入pkg模式 然后 up 再安装试试


#3

谢谢 :grin: 但是好像还是不行…
我用JuliaPro安装好多包都是这个问题,可能是我电脑的问题吧,julia配合juno用就没有什么问题了 :joy: