JuliaPro 1.0.1.1 Pkg test崩溃


#1
(...) pkg> test
   Testing (...)
 Resolving package versions...
fatal: error thrown and no exception handler available.
InitError(mod=:MbedTLS, error=MethodError(f=typeof(Base.Filesystem.joinpath)(), args=(nothing, "..", "..", "deps", "usr", "lib"), world=0x000000000000673a))
rec_backtrace at /home/Administrator/buildbot/worker/package_win64/build/src\stackwalk.c:94
record_backtrace at /home/Administrator/buildbot/worker/package_win64/build/src\task.c:246
jl_throw at /home/Administrator/buildbot/worker/package_win64/build/src\task.c:577
jl_method_error_bare at /home/Administrator/buildbot/worker/package_win64/build/src\gf.c:1616
jl_method_error at /home/Administrator/buildbot/worker/package_win64/build/src\gf.c:1634
jl_apply_generic at /home/Administrator/buildbot/worker/package_win64/build/src\gf.c:2161
__init__ at C:\Users\julia\AppData\Local\Julia-1.0.1\share\julia\stdlib\v1.0\MbedTLS\src\MbedTLS.jl:61
jfptr___init___21367 at C:\Users\twshe\Software\Julia\Julia-1.0.1\lib\julia\sys.dll (unknown line)
jl_apply_generic at /home/Administrator/buildbot/worker/package_win64/build/src\gf.c:2184
jl_apply at /home/Administrator/buildbot/worker/package_win64/build/src\julia.h:1537 [inlined]
jl_module_run_initializer at /home/Administrator/buildbot/worker/package_win64/build/src\toplevel.c:90
_julia_init at /home/Administrator/buildbot/worker/package_win64/build/src/home/Administrator/buildbot/worker/package_win64/build/src\init.c:813
julia_init__threading at /home/Administrator/buildbot/worker/package_win64/build/src\task.c:302
wmain at /home/Administrator/buildbot/worker/package_win64/build/ui\repl.c:227
__tmainCRTStartup at /usr/src/debug/mingw64-x86_64-runtime-5.0.3-1/crt\crtexe.c:329
mainCRTStartup at /usr/src/debug/mingw64-x86_64-runtime-5.0.3-1/crt\crtexe.c:212
BaseThreadInitThunk at C:\WINDOWS\System32\KERNEL32.DLL (unknown line)
RtlUserThreadStart at C:\WINDOWS\SYSTEM32\ntdll.dll (unknown line)
ERROR: Package (...) errored during testing

只查到一个类似的

该楼主通过remove JULIA_LOAD_PATH之后juliapro魔法般的work了,而我并没有这个环境变量。

怎么玩呢?


#2

可能得给Pkg.jl提issue了,Windows上的问题不是很了解。


#3

应该是Test标准库的bug.
我可以通过using+include(“test/runtests.jl”)成功测试。


#4

这个环境是 Pkg 提供的吧?


#5

就 juliapro装好后直接进Pkg CLI, 依赖可能是juliapro预置的。不过直接在官网下1.0.1的windows release也会有一样的问题。