CuArrays 安装后无法使用


#1

最近在尝试使用Julia GPU编程,按照教程顺序安装 “CuArrays”,“CUDAdrv”,“CUDAnative”,“GPUArrays”,“CUDAnative”。

教程网址:https://www.jianshu.com/p/7c3b1e1c3cbb

安装很顺利,已安装的库如下:
image
image

但是在使用using调用"CuArrays"时发生如下错误:

Julia版本为1.1.0,显卡为1050。目前除了"CuArrays",其余库都工作正常,想请教各位大佬应该如何操作


#2

驱动、CUDA、CUDNN都装了?对应的版本?


#3

刚才装上了,CUDA和CUDNN的版本都是10.1
image

我重新安装了一遍,觉得问题可能在安装的时候就有了。中间的警告我没搞懂,它说的注册表是指什么?


#4

那个registry不是windows下的注册表,是用来指定julia安装包的镜像源,默认就是general,这个提示是告诉你registry出错了,会影响后面安装和更新包。可以在pkg模式下,registry rm general 再 registry add general试下,还提示有错的话就只能暴力地删了.julia再试试了……

Anyway,从你第一个截图看应该是正常安装了,不过确实没遇到过你的这个问题,我目前在win10上跑的是cuda10.0,运行正常。不妨去英文的discourse上发个帖试试?


#5

果然还是重装Julia有效果。。。
我觉得首先可能是安装GPU模块需要按照一定次序,最好是先装相关驱动和cuda,然后再装Julia的包,次序不对可能会导致相关注册信息发生故障。其次,在Pkg模式下使用rm删除某个包,好像并没有删除文件,只是在Pkg里把相关注册信息删了,结果重新安装时只是把文件夹里的信息重新添加回来而已,原来是错的现在还是错的。正确方法是把C盘里面的包给删了,再重新下载。
非常感谢你的帮助:+1:


#6

在Pkg模式下用gc,能删除所有旧的Package的文件。