using IJulia报错,显示 MbedTLS未安装正确


#1

突然notebook提示服务停止,关掉后,想要重启,显示如下错误,已经用管理员身份重新build MbedTLS了

 julia> using IJulia
[ Info: Precompiling IJulia [7073ff75-c697-5162-941a-fcdaad2a7d2a]
ERROR: LoadError: MbedTLS not installed properly, run Pkg.build("MbedTLS"), restart Julia and try again
Stacktrace:
 [1] error(::String) at .\error.jl:33
 [2] top-level scope at D:\Users\Maxwell\AppData\Local\Julia-1.0.3\depot\packages\MbedTLS\XkQiX\src\MbedTLS.jl:43
 [3] include at .\boot.jl:317 [inlined]
 [4] include_relative(::Module, ::String) at .\loading.jl:1044
 [5] include(::Module, ::String) at .\sysimg.jl:29
 [6] top-level scope at none:2
 [7] eval at .\boot.jl:319 [inlined]
 [8] eval(::Expr) at .\client.jl:393
 [9] top-level scope at .\none:3
in expression starting at D:\Users\Maxwell\AppData\Local\Julia-1.0.3\depot\packages\MbedTLS\XkQiX\src\MbedTLS.jl:42
ERROR: LoadError: LoadError: Failed to precompile MbedTLS [739be429-bea8-5141-9913-cc70e7f3736d] to D:\Users\Maxwell\AppData\Local\Julia-1.0.3\depot\compiled\v1.0\MbedTLS\bf9T0.ji.
Stacktrace:
 [1] error(::String) at .\error.jl:33
 [2] compilecache(::Base.PkgId, ::String) at .\loading.jl:1203
 [3] _require(::Base.PkgId) at .\loading.jl:960
 [4] require(::Base.PkgId) at .\loading.jl:858
 [5] require(::Module, ::Symbol) at .\loading.jl:853
 [6] include at .\boot.jl:317 [inlined]
 [7] include_relative(::Module, ::String) at .\loading.jl:1044
 [8] include at .\sysimg.jl:29 [inlined]
 [9] include(::String) at D:\Users\Maxwell\AppData\Local\Julia-1.0.3\depot\packages\IJulia\GIANC\src\IJulia.jl:33
 [10] top-level scope at none:0
 [11] include at .\boot.jl:317 [inlined]
 [12] include_relative(::Module, ::String) at .\loading.jl:1044
 [13] include(::Module, ::String) at .\sysimg.jl:29
 [14] top-level scope at none:2
 [15] eval at .\boot.jl:319 [inlined]
 [16] eval(::Expr) at .\client.jl:393
 [17] top-level scope at .\none:3
in expression starting at D:\Users\Maxwell\AppData\Local\Julia-1.0.3\depot\packages\IJulia\GIANC\src\hmac.jl:1
in expression starting at D:\Users\Maxwell\AppData\Local\Julia-1.0.3\depot\packages\IJulia\GIANC\src\IJulia.jl:305
ERROR: Failed to precompile IJulia [7073ff75-c697-5162-941a-fcdaad2a7d2a] to D:\Users\Maxwell\AppData\Local\Julia-1.0.3\depot\compiled\v1.0\IJulia\nfu7T.ji.
Stacktrace:
 [1] error(::String) at .\error.jl:33
 [2] compilecache(::Base.PkgId, ::String) at .\loading.jl:1203
 [3] _require(::Base.PkgId) at .\loading.jl:960
 [4] require(::Base.PkgId) at .\loading.jl:858
 [5] require(::Module, ::Symbol) at .\loading.jl:853

(v1.0) pkg> build MbedTLS
  Building MbedTLS → `D:\Users\Maxwell\AppData\Local\Julia-1.0.3\depot\packages\MbedTLS\XkQiX\deps\build.log`
┌ Error: Error building `MbedTLS`:
│ ┌ Warning: platform_key() is deprecated, use platform_key_abi() from now on
│ │   caller = ip:0x0
│ └ @ Core :-1
│ [ Info: Downloading https://github.com/JuliaWeb/MbedTLSBuilder/releases/download/v0.17.0/MbedTLS.v2.16.0.x86_64-w64-mingw32.tar.gz to D:\Users\Maxwell\AppData\Local\Julia-1.0.3\depot\packages\MbedTLS\XkQiX\deps\usr\downloads\MbedTLS.v2.16.0.x86_64-w64-mingw32.tar.gz...
│ [ Info: Downloading https://github.com/JuliaWeb/MbedTLSBuilder/releases/download/v0.17.0/MbedTLS.v2.16.0.x86_64-w64-mingw32.tar.gz to D:\Users\Maxwell\AppData\Local\Julia-1.0.3\depot\packages\MbedTLS\XkQiX\deps\usr\downloads\MbedTLS.v2.16.0.x86_64-w64-mingw32.tar.gz...
│ ERROR: LoadError: Could not download https://github.com/JuliaWeb/MbedTLSBuilder/releases/download/v0.17.0/MbedTLS.v2.16.0.x86_64-w64-mingw32.tar.gz to D:\Users\Maxwell\AppData\Local\Julia-1.0.3\depot\packages\MbedTLS\XkQiX\deps\usr\downloads\MbedTLS.v2.16.0.x86_64-w64-mingw32.tar.gz:
│ ErrorException("")
│ Stacktrace:
│  [1] error(::String) at .\error.jl:33
│  [2] #download#93(::Bool, ::Function, ::String, ::String) at D:\Users\Maxwell\AppData\Local\Julia-1.0.3\depot\packages\BinaryProvider\4F5Hq\src\PlatformEngines.jl:498
│  [3] #download at .\none:0 [inlined]
│  [4] #download_verify#94(::Bool, ::Bool, ::Bool, ::Function, ::String, ::String, ::String) at D:\Users\Maxwell\AppData\Local\Julia-1.0.3\depot\packages\BinaryProvider\4F5Hq\src\PlatformEngines.jl:584
│  [5] #download_verify at .\none:0 [inlined]
│  [6] #install#133(::Prefix, ::String, ::Bool, ::Bool, ::Bool, ::Function, ::String, ::String) at D:\Users\Maxwell\AppData\Local\Julia-1.0.3\depot\packages\BinaryProvider\4F5Hq\src\Prefix.jl:314
│  [7] (::getfield(BinaryProvider, Symbol("#kw##install")))(::NamedTuple{(:prefix, :force, :verbose),Tuple{Prefix,Bool,Bool}}, ::typeof(install), ::String, ::String) at .\none:0
│  [8] top-level scope at D:\Users\Maxwell\AppData\Local\Julia-1.0.3\depot\packages\MbedTLS\XkQiX\deps\build.jl:48
│  [9] include at .\boot.jl:317 [inlined]
│  [10] include_relative(::Module, ::String) at .\loading.jl:1044
│  [11] include(::Module, ::String) at .\sysimg.jl:29
│  [12] include(::String) at .\client.jl:392
│  [13] top-level scope at none:0
│ in expression starting at D:\Users\Maxwell\AppData\Local\Julia-1.0.3\depot\packages\MbedTLS\XkQiX\deps\build.jl:44
│ ʹ�á�2���������á�DownloadFile��ʱ�����쳣:���� WebClient �����ڼ䷢���쳣����
│ ����λ�� ��:5 �ַ�: 1
│ + $webclient.DownloadFile("https://github.com/JuliaWeb/MbedTLSBuilder/r ...
│ + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
│     + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException
│     + FullyQualifiedErrorId : WebException
│
│ ʹ�á�2���������á�DownloadFile��ʱ�����쳣:
������ʱ��
│ ����λ�� ��:5 �ַ�: 1                                          LSBuilder/r ...
│ + $webclient.DownloadFile("https://github.com/JuliaWeb/MbedT~~~~~~~~~~~LSBuilder/r ...
│ + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~│     + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException
│     + CategoryInfo          : NotSpecified: (:) [], MethodInvocation          ild\usr\share\julia\stdlib\v1.0\Pkg\src\Operations.jl:1097│ + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~│     + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException│     + FullyQualifiedErrorId : WebException│└ @ Pkg.Operations C:\cygwin\home\Administrator\buildbot\worker\package_win64\build\usr\share\julia\stdlib\v1.0\Pkg\src\Operations.jl:1097

#2

网不好,挂个梯子试试。


#3

可以了 可能真是网络问题 thx