CPLEX使用出错


#1

电脑重装系统后重新安装了juliapro0.6.4.1和CPLEX12.8,之前是下载完就可以直接using CPLEX了,没有配置过其他东西。但今天using CPLEX出现了问题,提示CPLEX not properly installed,让我尝试build CPLEX(如图上部分)。我build CPLEX仍然报错,unable to locate CPLEX installation(如图下部分)。
我试过Pkg.add(’‘CPLEX’’)也是会报错。重新安装juliapro和CPLEX,也没有用。请问这个问题该如何解决?


#2

你要单独安装cplex


#3

我已经单独单装了CPLEX 12.8,我刚刚打开CPLEX的时候提示“OPL运行时不可用,请检查安装”,不知道julia报错是否是这个原因?还有就是CPLEX安装好后是否需要进行配置?我之前使用都是安装好了CPLEX和julia就可以用了。


#4

你的报错显示找不到CPLEX,那么很有可能就是你的路径错误。你可以阅读一下Julia的CPLEX.jl的README重新装一下试试。


#5

打开CPLEX提示OPL运行时不可用,重新下载安装了Visual C++之后问题就解决了。非常感谢!