CUDArt


#1

pkg > add CUDArt 出错
具体错误信息

(v1.1) pkg> add CUDArt
 Resolving package versions...
ERROR: Unsatisfiable requirements detected for package CUDArt [58537def]:
 CUDArt [58537def] log:
 ├─possible versions are: [0.0.1, 0.1.0-0.1.3, 0.2.0-0.2.3, 0.3.0-0.3.2, 0.4.0-0.4.1] or uninstalled
 ├─restricted to versions * by an explicit requirement, leaving only versions [0.0.1, 0.1.0-0.1.3, 0.2.0-0.2.3, 0.3.0-0.3.2, 0.4.0-0.4.1]
 ├─restricted by compatibility requirements with CUDAdrv [c5f51814] to versions: [0.0.1, 0.1.0-0.1.3, 0.2.0-0.2.3] or uninstalled, leaving only versions: [0.0.1, 0.1.0-0.1.3, 0.2.0-0.2.3]
 │ └─CUDAdrv [c5f51814] log:
 │   ├─possible versions are: [0.1.0-0.1.1, 0.2.0-0.2.4, 0.3.0-0.3.1, 0.4.0-0.4.2, 0.5.0-0.5.4, 0.6.0-0.6.1, 0.7.0-0.7.8, 0.8.0-0.8.6, 0.9.0, 1.0.0-1.0.1, 2.0.0, 3.0.0] or uninstalled
 │   └─restricted to versions 3.0.0 by an explicit requirement, leaving only versions 3.0.0
 └─restricted by julia compatibility requirements to versions: uninstalled — no versions left

删除根目录.julia后重新安装,进图条读完后又显示同样的错误


#2

你好,解决了嘛,同样无法安装


#3

我感觉他可能是一个子包,因为我在安装Clang和CuArrays时出现了安装CUDArt的信息


#4

我明白了,CUDArt 只支持到比较早的 julia 版本,新的用不了,要用的话要去用老的 julia 版本


#5

它现在是一个子包

(v1.1) pkg> rm  CuArrays
  Updating `C:\Users\Dragon\.julia\environments\v1.1\Project.toml`
  [3a865a2d] - CuArrays v1.0.2
  Updating `C:\Users\Dragon\.julia\environments\v1.1\Manifest.toml`
  [621f4979] - AbstractFFTs v0.4.0
  [79e6a3ab] - Adapt v0.4.2
  [00ebfdb7] - CSTParser v0.5.2
  [3895d2a7] - CUDAapi v0.6.3
  [c5f51814] - CUDAdrv v3.0.0
  [be33ccc6] - CUDAnative v2.1.0
  [34da2185] - Compat v2.1.0
  [8f4d0f93] - Conda v1.2.0
  [a8cc5b0e] - Crayons v4.0.0
  [3a865a2d] - CuArrays v1.0.2
  [7a1cc6ca] - FFTW v0.2.4
  [1a297f60] - FillArrays v0.6.1
  [0c68f7d7] - GPUArrays v0.7.0
  [929cbde3] - LLVM v1.1.0
  [1914dd2f] - MacroTools v0.5.0
  [872c559c] - NNlib v0.6.0
  [189a3867] - Reexport v0.2.0
  [ae029012] - Requires v0.5.2
  [90137ffa] - StaticArrays v0.10.3
  [a759f4b9] - TimerOutputs v0.5.0
  [0796e94c] - Tokenize v0.5.3
  [81def892] - VersionParsing v1.1.3
  [8bb1440f] - DelimitedFiles
  [37e2e46d] - LinearAlgebra
  [1a1011a3] - SharedArrays
  [2f01184e] - SparseArrays
  [10745b16] - Statistics

(v1.1) pkg> add CuArrays
 Resolving package versions...
  Updating `C:\Users\Dragon\.julia\environments\v1.1\Project.toml`
  [3a865a2d] + CuArrays v1.0.2
  Updating `C:\Users\Dragon\.julia\environments\v1.1\Manifest.toml`
  [621f4979] + AbstractFFTs v0.4.0
  [79e6a3ab] + Adapt v0.4.2
  [00ebfdb7] + CSTParser v0.5.2
  [3895d2a7] + CUDAapi v0.6.3
  [c5f51814] + CUDAdrv v3.0.0
  [be33ccc6] + CUDAnative v2.1.0
  [34da2185] + Compat v2.1.0
  [8f4d0f93] + Conda v1.2.0
  [a8cc5b0e] + Crayons v4.0.0
  [3a865a2d] + CuArrays v1.0.2
  [7a1cc6ca] + FFTW v0.2.4
  [1a297f60] + FillArrays v0.6.1
  [0c68f7d7] + GPUArrays v0.7.0
  [929cbde3] + LLVM v1.1.0
  [1914dd2f] + MacroTools v0.5.0
  [872c559c] + NNlib v0.6.0
  [189a3867] + Reexport v0.2.0
  [ae029012] + Requires v0.5.2
  [90137ffa] + StaticArrays v0.10.3
  [a759f4b9] + TimerOutputs v0.5.0
  [0796e94c] + Tokenize v0.5.3
  [81def892] + VersionParsing v1.1.3
  [8bb1440f] + DelimitedFiles
  [37e2e46d] + LinearAlgebra
  [1a1011a3] + SharedArrays
  [2f01184e] + SparseArrays
  [10745b16] + Statistics

我重新安装了给你看一下。

其中有一项就是CUDArt