vscode无法使用Julia扩展,求解


#1

The julia Language Server server crashed 5 times in the last 3 minutes. The server will not be restarted.


#2

你需要提供一些更详细的信息别人才能理解你的问题
例如:之前是否成功使用过;是如何安装的;有无额外的配置;是什么系统。


#3

我是第一次在vscode安装Julia扩展,Julia语言是1.0.1 vscode是1.35 系统是win10 64bit
报错信息如下
ERROR: LoadError: EOFError: read end of file

Stacktrace:

[1] read at .\iobuffer.jl:207 [inlined]

[2] read at .\stream.jl:758 [inlined]

[3] read(::Pipe, ::Type{UInt8}) at .\io.jl:229 (repeats 2 times)

[4] deserialize at C:\Users\julia\AppData\Local\Julia-1.0.1\share\julia\stdlib\v1.0\Serialization\src\Serialization.jl:703 [inlined]

[5] deserialize(::Base.Process) at C:\Users\julia\AppData\Local\Julia-1.0.1\share\julia\stdlib\v1.0\Serialization\src\Serialization.jl:700

[6] request(::SymbolServerProcess, ::Symbol, ::Nothing) at c:\Users\wfl56.vscode\extensions\julialang.language-julia-0.11.6\scripts\languageserver\packages\SymbolServer\src\SymbolServer.jl:39

[7] get_installed_packages_in_env(::SymbolServerProcess) at c:\Users\wfl56.vscode\extensions\julialang.language-julia-0.11.6\scripts\languageserver\packages\SymbolServer\src\SymbolServer.jl:108

[8] getstore(::SymbolServerProcess) at c:\Users\wfl56.vscode\extensions\julialang.language-julia-0.11.6\scripts\languageserver\packages\SymbolServer\src\SymbolServer.jl:67

[9] macro expansion at .\logging.jl:307 [inlined]

[10] run(::LanguageServerInstance) at c:\Users\wfl56.vscode\extensions\julialang.language-julia-0.11.6\scripts\languageserver\packages\LanguageServer\src\languageserverinstance.jl:33

[11] top-level scope at c:\Users\wfl56.vscode\extensions\julialang.language-julia-0.11.6\scripts\languageserver\main.jl:26 [inlined]

[12] top-level scope at .\none:0

[13] include at .\boot.jl:317 [inlined]

[14] include_relative(::Module, ::String) at .\loading.jl:1041

[15] include(::Module, ::String) at .\sysimg.jl:29

[16] exec_options(::Base.JLOptions) at .\client.jl:229

[17] _start() at .\client.jl:421

in expression starting at c:\Users\wfl56.vscode\extensions\julialang.language-julia-0.11.6\scripts\languageserver\main.jl:5

[Error - 下午4:19:47] Connection to server got closed. Server will not be restarted.


#4

去github给插件发issue吧


#5

最近更新了,你卸载重装一下试试?我之前也遇到这个情况,卸载重装又好了。