JuliaPro怎么改变julia版本?


#1

我之前下载的是JuliaPro0.6,现在想用julia1.0或更高版本,不想重新再下一遍JuliaPro了,需要如何更换julia的路径?

我记得我前几天用的时候直接在package-julia-setting中修改julia的路径就可以了:
image

但是最近不知道为什么不行了,出现了错误:

然后我又试了julia1.2.0,出现了一样的错误,但是成功打开了julia,但我选中代码run block没有任何反应:

有没有人指导一下?


#2


你的JuliaPro插件用到了shift!方法,它已经过时,并且在1.0以后的版本中不再存在,对应的等价物是popfirst!。因此你用1.0以后的Julia环境是跑不起来的。

建议你下载最新的JuliaPro。


#3

好的,感谢!但还有一点疑问,我今天用julia0.7也出现了同样的报错,但我前几天还是可以在juliapro中运行julia0.7的,这是为什么呢?


#4

你确定你启动的JuliaPro的环境是0.7吗?
0.7给这些函数加上了deprecated警告,但是并没有移除


#5

我在package-julia-setting里面把julia path改成julia0.7的路径了,我以前也是这么干的,以前是可以的。
不过这次报错跟之前不一样:

我试了一下using DocSeeker,还是报错:
image


#6

没用过这个包…应该是里面的一些语法有问题,你试试这个包有没有其他版本的