求助:JuliaPro v0.5中安装老版本的一个包Ipopt.jl

我要复现歪果友仁的程序,他用的julia v0.5编写的,两年前搞的,用的包也是当时版本的包,为了Julia版本匹配,我就下了juliapro v0.5,想安Ipopt v0.2.6版的,链接如下:https://github.com/JuliaOpt/Ipopt.jl/tree/v0.2.6,我试过Pkg.add(“Ipopt”),但新版本的就是安不上,试过Pkg.pin,Pkg.clone等等方法,都无法将Ipopt v0.2.6的安上,求助各位大神,有啥方法安上的,本地安装,网络安装?多谢帮助!!

Pkg.status()
173 required packages:

  • ASTInterpreter 0.0.4
  • AbstractTrees 0.0.4
  • ArgParse 0.5.0
  • JuMPChance 0.4.0 master
    Juliapro v0.5包很多,JuMPChance.jl就是直接Pkg.clone过来的,因为他这个也是基于Julia 0.5开发的,,求助安Ipopt v0.2.6

哪个包?是开源的或者论文里的就给个地址。

都进行复现了,就改一改吧改成 1.0 的。

另一个帖子也是 0.5 的代码,我给升级到 1.0 差不多 20 几个 commit。

如下方法 + google 就够了。(其实看懂了重写更快

Ipopt.jl这个包,我想在juliav0.5 中把它安上,才能正常运行复现,得安Ipopt.jl v0.2.6的才能完整运行出结果,升级成1.0难度有点大呀,新手才开始摸索

京ICP备17009874号-2