大神急求,请帮帮忙,所有方法都试过了

我已经在julia里ENV【“PYTHON”】过,而且也build PyCall正常,没有报错,为什么我一using AutoEnvs的时候,还出现这个错误,关键是以前也出现过相同的错误,我就是按照以前的办法解决,还是不行,还一直出现这个错误,就算退出julia重新进入还不行,求大神帮帮忙

当前配置的Python需要安装matplotlib包(或许你该看下错误信息的)

其实你也可以试下,不设置ENV[“PYTHON”],直接using AutoEnvs

大神,是这样的,我已经装过matplotlib了,而且路径正确,最令我无语的是,前两周报过一模一样的错误,按那种方法解决正确了,这回我就是按照同样的方法解决,却不行了,我也试过直接using AutoEnvs还是出现相同错误,所以令我崩溃了

你切换到 rllab3这个env下,然后确认下是不是已经装过 matplotlib

用pip3安装matplotlib,可以用清华的pypi源

各位大神,不行,我这个是在conda环境里安装过matplotlib,并且我又在conda环境里已经pip安装过matplotlib了,我把julia配置的路径是conda里的python路径还是不行,,,

pip3!!!,再试一试,你用的是ubuntu啊

嗯嗯,已经好了:grin:

f603918fa0ec08fabf1e114b52ee3d6d54fbdac4
FA♂Q

京ICP备17009874号-2