新人毕设求助:The following package names could not be resolved

因为毕设原因刚刚接触Julia,用的Juliapro,安装库一直报错,卡了好几天了,希望大佬援手!

  1. Julia 的版本信息!
    Julia Version 1.2.0
    Commit c6da87ff4b (2019-08-20 00:03 UTC)
    Platform Info:
    OS: Windows (x86_64-w64-mingw32)
    CPU: Intel® Core™ i5-6300HQ CPU @ 2.30GHz
    WORD_SIZE: 64
    LIBM: libopenlibm
    LLVM: libLLVM-6.0.1 (ORCJIT, skylake)
    Environment:
    JULIA_EDITOR = “F:\julia\juliapro\app-1.40.1\atom.exe” -a
    JULIA_NUM_THREADS = 2
    JULIA_PKG_SERVER = https://kr.pkg.julialang.org
    JULIA_PKG_TOKEN_PATH = C:\Users\Administrator.juliapro\token.toml
  2. 当前包管理器的状态!
    julia> using Pkg; Pkg.status()
    Status C:\Users\Administrator\.juliapro\JuliaPro_v1.2.0-1\environments\v1.2\Project.toml
    [7d9fca2a] Arpack v0.3.1
    [c52e3926] Atom v0.9.1
    [7073ff75] IJulia v1.19.0
    [e5e0dc1b] Juno v0.7.1
    [0729bffe] POMDPToolbox v0.3.0
    [a93abf59] POMDPs v0.7.2
    [c8b314e2] ParticleFilters v0.3.2
  3. 完整的安装失败的错误信息3

遇到问题请先自己搜索解决办法,这次我帮你找了,另外,代码建议使用 Markdown 格式写,不建议贴图。
你要的答案见 https://github.com/JuliaPOMDP/BasicPOMCP.jl
另外,现在最新的 Julia 是1.4.1 了

好的,谢谢大佬。

大佬,我按GitHub上的方法试了,但是在add的时候报了下面的错误:
ERROR: Unsatisfiable requirements detected for package POMDPs [a93abf59]:
POMDPs [a93abf59] log:
├─possible versions are: 0.8.3 or uninstalled
├─restricted to versions [0.7.3-0.7, 0.9.0-0.9] by QMDP [3aa3ecc9] — no versions left
│ └─QMDP [3aa3ecc9] log:
│ ├─possible versions are: 0.1.3 or uninstalled
│ └─QMDP [3aa3ecc9] is fixed to version 0.1.3
└─POMDPs [a93abf59] is fixed to version 0.8.3

自己查了一下,好像是版本兼容问题,请问有什么解决方法吗

依赖关系满足不了,可以试试升级新版本或者滚回老版本

好的,谢谢解惑。