build TrajectoryOptimization 时找不到"Pkg"

在build TrajectoryOptimization 时出现报错
“ Error: Error building TrajectoryOptimization:
│ ERROR: LoadError: ArgumentError: Package Pkg not found in current path:
│ - Run import Pkg; Pkg.add("Pkg") to install the Pkg package.

│ Stacktrace:
│ [1] require(::Module, ::Symbol) at .\loading.jl:892
│ [2] include(::String) at .\client.jl:439
│ [3] top-level scope at none:5
│ in expression starting at C:\Users\jkklz.juliapro\JuliaPro_v1.4.2-1\packages\TrajectoryOptimization\sRBs7\deps\build.jl:1
└ @ Pkg.Operations C:\Users\julia\AppData\Local\Julia-1.4.2\share\julia\stdlib\v1.4\Pkg\src\Operations.jl:892

请教这是环境变量的问题吗?需要怎么排除解决呢?谢谢吴彦祖们!

你的代码就这一行吗,有没有详细一点的信息
ps: 叫我大帅比

1 个赞

你装的是什么版本的 TrajectoryOptimization ? 现在最新的是 v0.3.0

1 个赞


Yubinwang

1 分钟

您好,使用的是v0.1.0版本的ADMM分支,在build时出现 Error: Error building TrajectoryOptimization :
│ ERROR: LoadError: ArgumentError: Package Pkg not found in current path:
│ - Run import Pkg; Pkg.add("Pkg") to install the Pkg package.
请问我应该怎么排除解决这个问题呢?
刚接触julia ,请谅解,感谢!

吴彦祖你好 ,repl内情况如下
Building Blink ─────────────────→ C:\Users\jkklz\.juliapro\JuliaPro_v1.4.2-1\packages\Blink\u1xcH\deps\build.log
Building MeshCat ───────────────→ C:\Users\jkklz\.juliapro\JuliaPro_v1.4.2-1\packages\MeshCat\ECbzr\deps\build.log
Building TrajectoryOptimization → C:\Users\jkklz\.juliapro\JuliaPro_v1.4.2-1\packages\TrajectoryOptimization\sRBs7\deps\build.log
┌ Error: Error building TrajectoryOptimization:
│ ERROR: LoadError: ArgumentError: Package Pkg not found in current path:
│ - Run import Pkg; Pkg.add("Pkg") to install the Pkg package.

│ Stacktrace:
│ [1] require(::Module, ::Symbol) at .\loading.jl:892
│ [2] include(::String) at .\client.jl:439
│ [3] top-level scope at none:5
│ in expression starting at C:\Users\jkklz.juliapro\JuliaPro_v1.4.2-1\packages\TrajectoryOptimization\sRBs7\deps\build.jl:1
└ @ Pkg.Operations C:\Users\julia\AppData\Local\Julia-1.4.2\share\julia\stdlib\v1.4\Pkg\src\Operations.jl:892
感觉是在执行deps/build.jl时无法找到Pkg标准库
build.jl文件内容如下
using Pkg
Pkg.add(PackageSpec(url=“https://github.com/RoboticExplorationLab/MatrixCalculus.jl.git”))
期待你的回复,谢谢!

ooops!这是一个依赖的问题,查看project.toml时发现没有Pkg的相关信息,添加了Pkg依赖后build通过。
查阅了一些资料,但是对已有项目二次开发的环境搭建了解甚少,虽然不想做伸手党,但无奈查阅了手册后理解仍然支离破碎。请问除了手册,我想实现对已有项目二次开发的环境搭建,有其他的参考资料吗?或者说有什么值得注意的地方呢?
不胜感激!

吴彦祖你好,修改了project文件添加Pkg依赖后解决了这个问题。

有点记不太清楚了,好像Julia 1.1开始不允许直接使用标准库,而需要将他们添加到Project.toml里,你用的这个版本的代码估计是用Julia 1.0写的

可以看看Julia的Pkg文档

可能确实是这个原因,感谢回复

谢谢您的帮助 :smiling_face_with_three_hearts: