安装julia-client失败

julia-client是在Atom里装的

在atol里装不上,我就试了下在julia REPL装,就是上面提示的错误

julia-client 是Atom 的库,只能够在Atom里安装。我也遇到过安装失败,尤其是更新的时候,不知道为什么经常失败。不过你重启Atom之后,再到settings -> Install 里搜索julia-client,重新安装一遍,大概率会成功。

这是两个东西,不互通的,Atom命令行用apm装

用apm装也提示失败,我看了下错误信息,难道是python版本和julia-client 0.7.6不兼容?
gyp ERR! stack Error: Python executable “D:\Anaconda3\python.EXE” is v3.6.5, which is not supported by gyp.

C:\Users\vtchen.atom\packages\atom-julia-client-0.7.6>apm install

Installing modules failed

node-pty-prebuilt@0.7.6 install C:\Users\vtchen.atom\packages\atom-julia-client-0.7.6\node_modules\node-pty-prebuilt
prebuild-install || node scripts/install.js

C:\Users\vtchen.atom\packages\atom-julia-client-0.7.6\node_modules\node-pty-prebuilt>if not defined npm_config_node_gyp (node “C:\Users\vtchen\AppData\Local\atom\app-1.30.0\resources\app\apm\node_modules\npm\bin\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild --build_v8_with_gn=false ) else (node “C:\Users\vtchen\AppData\Local\atom\app-1.30.0\resources\app\apm\bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild --build_v8_with_gn=false )
julia-client@0.7.6 C:\Users\vtchen.atom\packages\atom-julia-client-0.7.6
±- atom-package-deps@4.6.2
| ±- atom-package-path@1.1.0
| | -- sb-callsite@1.1.2 | +-- sb-fs@3.0.0 | | +-- sb-promisify@2.0.2 | |– strip-bom-buf@1.0.0
| | -- is-utf8@0.2.1 |– semver@5.5.1
±- atom-space-pen-views@2.2.0
| ±- fuzzaldrin@2.1.0
| -- space-pen@5.1.2 | +-- grim@1.5.0 | |– emissary@1.3.3
| | ±- es6-weak-map@0.1.4
| | | ±- d@0.1.1
| | | ±- es5-ext@0.10.46
| | | | ±- es6-iterator@2.0.3
| | | | | -- d@1.0.0 | | | | +-- es6-symbol@3.1.1 | | | |– next-tick@1.0.0
| | | ±- es6-iterator@0.1.3
| | | -- es6-symbol@2.0.1 | | +-- mixto@1.0.0 | |– property-accessors@1.1.3
| -- jquery@2.1.4 +-- coffee-script@1.12.7 +-- etch@0.14.0 +-- physical-cpu-count@2.0.0– underscore-plus@1.6.8
`-- underscore@1.8.3

npm WARN deprecated coffee-script@1.12.7: CoffeeScript on NPM has moved to “coffeescript” (no hyphen)
prebuild-install WARN install unexpected end of file
gyp ERR! configure error
gyp ERR! stack Error: Python executable “D:\Anaconda3\python.EXE” is v3.6.5, which is not supported by gyp.
gyp ERR! stack You can pass the --python switch to point to Python >= v2.5.0 & < 3.0.0.
gyp ERR! stack at failPythonVersion (C:\Users\vtchen\AppData\Local\atom\app-1.30.0\resources\app\apm\node_modules\node-gyp\lib\configure.js:454:14)
gyp ERR! stack at C:\Users\vtchen\AppData\Local\atom\app-1.30.0\resources\app\apm\node_modules\node-gyp\lib\configure.js:443:9
gyp ERR! stack at ChildProcess.exithandler (child_process.js:197:7)
gyp ERR! stack at emitTwo (events.js:106:13)
gyp ERR! stack at ChildProcess.emit (events.js:191:7)
gyp ERR! stack at maybeClose (internal/child_process.js:877:16)
gyp ERR! stack at Socket. (internal/child_process.js:334:11)
gyp ERR! stack at emitOne (events.js:96:13)
gyp ERR! stack at Socket.emit (events.js:188:7)
gyp ERR! stack at Pipe._handle.close [as _onclose] (net.js:498:12)
gyp ERR! System Windows_NT 10.0.16299
gyp ERR! command “C:\Users\vtchen\AppData\Local\atom\app-1.30.0\resources\app\apm\bin\node.exe” “C:\Users\vtchen\AppData\Local\atom\app-1.30.0\resources\app\apm\node_modules\node-gyp\bin\node-gyp.js” “rebuild” “–build_v8_with_gn=false”
gyp ERR! cwd C:\Users\vtchen.atom\packages\atom-julia-client-0.7.6\node_modules\node-pty-prebuilt
gyp ERR! node -v v6.9.5
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok
npm ERR! Windows_NT 10.0.16299
npm ERR! argv “C:\Users\vtchen\AppData\Local\atom\app-1.30.0\resources\app\apm\bin\node.exe” “C:\Users\vtchen\AppData\Local\atom\app-1.30.0\resources\app\apm\node_modules\npm\bin\npm-cli.js” “–globalconfig” “C:\Users\vtchen\.atom\.apm\.apmrc” “–userconfig” “C:\Users\vtchen\.atom\.apmrc” “install” “–runtime=electron” “–target=2.0.5” “–arch=x64”
npm ERR! node v6.9.5
npm ERR! npm v3.10.10
npm ERR! code ELIFECYCLE

npm ERR! node-pty-prebuilt@0.7.6 install: prebuild-install || node scripts/install.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the node-pty-prebuilt@0.7.6 install script ‘prebuild-install || node scripts/install.js’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the node-pty-prebuilt package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! prebuild-install || node scripts/install.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs node-pty-prebuilt
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls node-pty-prebuilt
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! C:\Users\vtchen.atom\packages\atom-julia-client-0.7.6\npm-debug.log

京ICP备17009874号-2