安装Plots出错


为什么Plots这个包安装不上呢?

Pkg.update()一下试试

您好,试过了,还是这样。搞不明白

Pkg.status()versioninfo() 发一下

这是Pkg.status()的结果

这是versioninfo()的结果

试试单安一下Pkg.add("Contour")

嗯嗯,我试一下哈

还是不行啊

安装其它的库正常吗

不知道您指的其他库是什么库。前几天装了PyPlot,是正常的,可以使用。就是好奇这个Plots为什么就装不上呢?

我之前遇到这种giterror,一般都选择把.cache都给删了,实在不行把整个.julua全删了重新装,不过换到0.7之后,再也没有这种错误了

还有就是通常add的时候好慢啊,我一般都用的是流量搞。那我试试0.7吧

啊,那得心疼下流量了……

可以用pkg3,或者直接换0.7-dev(或者等等1.0)


我现在用的是julia-0.7.0-rc2.我Pkg.add(“Plots”)时出现一个警告,意思是0.7后都不能Pkg.add了吗?还有您说的pkg3意思是pkg3.add(“Plots”)吗?

我试了下没啥问题,按@Jun说的,你试试清一下Contour这个库的cache吧。

另外,Win7的话会遇到一个别的giterror,需要装一下 https://julialang.org/downloads/

Windows 7/Windows Server 2012 users also require TLS “Easy Fix” update, and Windows Management Framework 3.0 or later

嗯嗯,我试一下哈

v0.7按 ] 进入package mode再 add, 具体看文档吧:https://docs.julialang.org/en/latest/stdlib/Pkg/#Adding-packages-1

如果还是不行,可以把 LOAD_PATH 变量里面的路径给删掉,然后重新Pkg.add试试

请问一下,怎样操作啊?