为什么下载registry的时候必须得设置git代理

不设置git代理但是终端已经翻墙:


无法下载registry。
设置git代理:

正常下载registry。
设置git代理虽然不麻烦,但是还得额外下载git for windows,然后再设置,或者直接在个人文件夹下写.gitconfig,有点麻烦了,在julia里没有环境变量来设置其自带的libgit2的配置吗?
并且pkgserver为什么没法用,registry没法下载,还有一些包根本没用到artifacts的新特性。详见:julia1.4-rc1 的ffmpeg的二进制依赖不走pkgserver

京ICP备17009874号-2